Why can't I download Flipp?

Modified on: 2016-09-06 14:57:55 -0400


iOS:

Flipp has a minimum requirement of iOS 8.0+, anything below this will not be compatible with Flipp. 


Android:

Flipp has a minimum requirement of 4.4+ since the launch. You can check your Android version via (Settings > About phone > Android version). 


Still having issues downloading Flipp? Email us at flippsupport@flipp.com with your Postal Code and let us know your specific scenario.


Did you find it helpful? Yes No

Can you please tell us how we can improve this article?